Discussions

Ask a Question
Back to All

rebar3 eunit symlink failure

This has started happening more and more and so far the only workaround is to rm -fr _build which is of course irritating as I have to then wait for everything to download and rebuild.

The problem is something to do with a symlink:

$ rebar3 eunit
rebar3 eunit
===> Verifying dependencies...
cp: symlink: [email protected]: File exists
===> sh(cp -Rp /Users/sean/Documents/code/erlang/scofblog/test/newcomment_h_test.erl /Users/sean/Documents/code/erlang/scofblog/test/activate_h_test.erl /Users/sean/Documents/code/erlang/scofblog/test/activate_impl_SUITE.erl /Users/sean/Documents/code/erlang/scofblog/test/newcomment_impl_SUITE.erl /Users/sean/Documents/code/erlang/scofblog/test/#newcomment_h_test.erl# /Users/sean/Documents/code/erlang/scofblog/test/messages_test.erl /Users/sean/Documents/code/erlang/scofblog/test/lifecycle_test_SUITE.erl /Users/sean/Documents/code/erlang/scofblog/test/.#newcomment_h_test.erl /Users/sean/Documents/code/erlang/scofblog/test/rebar.lock /Users/sean/Documents/code/erlang/scofblog/test/utils_test.erl /Users/sean/Documents/code/erlang/scofblog/test/dbms_SUITE.erl /Users/sean/Documents/code/erlang/scofblog/test/testhelp.erl /Users/sean/Documents/code/erlang/scofblog/test/comment_impl_SUITE.erl "/Users/sean/Documents/code/erlang/scofblog/_build/test/lib/scofblog/test")
failed with return code 1 and the following output:
cp: symlink: [email protected]: File exists

FAIL: 1

I have no idea what I did to make this happen, I've been working on this particular project for a while without issue and then without warning it started happening. I don't have any idea of a cause other then could it be related to me writing EUnit tests that fail a lot before I get them to pass?!?!?!